From Command Lookup Tool:
neighbor default-originate
To allow a BGP speaker (the local router) to send the default route 0.0.0.0 to a neighbor for use as a default route, use the neighbor default-originate command in address family or router configuration mode.
LAB Setup:
Router A
interface Serial1/0
ip address 10.1.1.1 255.255.255.252
serial restart-delay 0
no synchronization
bgp log-neighbor-changes
neighbor 10.1.1.2 remote-as 1
no auto-summary
Router B
interface Serial1/0
ip address 10.1.1.2 255.255.255.252
serial restart-delay 0
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 10.1.1.1 remote-as 1
neighbor 10.1.1.1 default-originate
no auto-summary
!
ip route 0.0.0.0 0.0.0.0 10.1.33.251
Here in router A you will see that router B's default route is successfully advertised to Router A by issuing Show ip bgp command and Show ip route. |